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1 Introduction 

As demands for productivity in the use of software has increased, the ability to 

execute processes efficiently with quality control has become increasingly more 

important. The efficient execution of the product creation and test execution of 

software processes enhances product quality and stakeholder satisfaction. 

 

This document discusses step by step instruction on how to migrate your development 

environment to the test environment to help ensure the quality of your software 

development 

 

2 Background 

Software testing is one of the key components in the software development.  It aims at 

evaluating capability of a program or system and determining that it meets its required 

results before it goes into to production.  Before the product can be released into the 

production environment, we will be using the testing environment area for quality 

assurance. Even though testing can never completely identify all the defects within 

software but it still an important piece that will allow us to mitigate risks before the 

product is roll out.  

 

 

3 Agenda 

For the remainder of this documentation, we will primarily discuss: 

 

I. Information that needs to be captured from Rational Asset Manager 

Development Environment before you can start your migration process. 

 

II. How to capture the Rational Team Concert Development Environment 

Workflow from Development Environment 

 

III. How to recreate your Rational Asset Manager v7.2 Development Environment 

on the Test environment 

 

IV. How to import Library from Development environment to the Test 

environment 
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4 Information to be captured before migration 

Information that needs to be captured from Rational Asset Manager Development 

Environment before you can start your migration process. 

 

For our example, we will be using the “export library” to help us export the assets 

from one environment to the next. For the small number of assets using the “export 

library” is suitable for this task.  However, if the creation of export files starts to get 

very big then you  may want to consider using the “batch uploader” tool instead.   

 

4.1   Create the library (zip file) 

 

a. Login as the Administrator and click Libraries 

 

 
 

 

b. Select “New Library”. 

If you want to clone the exact copy from this Rational Asset Manager 

server, you need to select everything and add them into the library that we 

are about to create. This will copy the communities, user groups, assets, 

and the information model (Asset Types, Category Schemas, Asset 

Attributes, and Relationships). It will NOT (in Rational Asset Manager 

v7.2) copy the lifecycle configurations for the communities. 
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c. To select all of “Asset Type”, click on the second checkbox under “Asset 

Type” will bring all of the asset types to your library.  If you want to pick 

and choose one or the other but not all of the asset type  > expanding this 

icon on the right  

 

 
 

d. Select “Category Schemas” and select all.  

 

 
 

e. Select “Relationship” and select all.  
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f. Select “Asset Attribute” by clicking at the second checkbox under “Asset 

Attribute” will add all of the Asset Attribute to your library. 

 

If you want to pick and choose one or the other but not all of the attribute 

by expanding on this icon on the right  

 

 
 

g. Select “All Asset” > Click on this icon   will bring up the Search for 

Assets page.  Type in “*”  to search for all asset 

 

 
 

h. Once the “Search for Assets” returns all the assets that it found > Click on 

Tasks > Add all results 

 

Note:  Add all results might take awhile to complete. It’s depending on the 

size of your assets and how many asset it has to bring in to the library. 

Basically the library is just of the big “zip” file that we will be bringing in 

to the Rational Asset Manager Test Environment 
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i. Once it’s completed you will see the confirmation that these assets have 

been added to the library 

 

 

j. Select “Tasks” > View Library 
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k. List of the “Asset that show you just added is now showing up on the 

“Create Library page” 

 

 

 

l. Click “Create and Enable” at the bottom right corner of this page.  

 

 
 

m. One it’s done you should see the new library that you just created listed 

under the “Libraries” Name 

 

 

 

 

 

 

 

 

 

 



     

 

                                  Page 10 of 42                                Rational Support Whitepaper 
   

 

n. Click on Version then “Export” to a zip file 
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4.2 Capture Information about the Community Lifecycle 

Now we need to capture the information about the community lifecycles since they 

are not included in the asset library export. To do this perform the following for each 

community lifecycle 

 

a. Take a screenshot of the lifecycle, such as the one shown below 
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b. For each state AND transition, take a screenshot or write down the 

information about the collaborators, reviewers, the policies that are 

selected and their configuration, and the conditions for the transition to 

occur 
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5 Capture Development Environment Workflow 

Capture the Rational Team Concert Development Environment Workflow from the 

Development Environment 

 

1. Open the RAM Lifecycle project area 

 

 
 

2. Select the Process Configuration tab 

 

 
 

3. Expand the Project Configuration > Configuration Data section, select the 

Type Category that is mapped to the workflow you are migrating and take 

a screen shot (such as the one below). This will be used later for entering 

into the next Rational Team Concert environment. 
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4. Select the Workflow Binding section and select the Type Category (as 

shown below) to illustrate the binding to the workflow; and take a screen 

shot. 

 

 

 

5. Select the Workflows section in the tree (as shown below) and then select 

the Workflow to edit in the dropdown box (as shown below). 
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6. Take screenshots of the Workflow page, be sure to capture the Start 

Action, Transitions, the States, and the Actions 

 

 
 

Transitions 

 
 

States 
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Actions 
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6 Recreate Development Environment in Test Environment 

Recreate your Rational Asset Manager 7.2 Development Environment on the Test 

environment 

 

Rational Team Concert (Test Environment) 

 

From the Rational Team Concert client (Test Environment), you need to create the 

Rational Team Concert workflow on the Test environment 

Create a workflow by using the Rational Team Concert client (Test 

Environment) 

To create a workflow: 

1. From the Rational Team Concert client, connect to the Rational Team Concert 

server that was supplied with Rational Asset Manager. You must use the same 

server URL for the Rational Team Concert connection that is set for the 

Rational Team Concert server that was supplied with Rational Asset Manager. 

To find the URL, Using the Rational Asset Manager admin account to login to 

the Rational Asset Manager Server a, click Administration > Configuration > 

Internal Rational Team Concert Path > Path.  

You must use the same Web server admin credentials to log in to this new 

connection. You must connect to the RAM Lifecycle project area the first time 

in your Rational Team Concert client. Afterwards, if you are connected, you 

will see the RAM Lifecycle project area. 

 

2. Open the RAM Lifecycle project area 

 

 
 

 



     

 

                                  Page 18 of 42                                Rational Support Whitepaper 
   

 

3. Select the Process Configuration tab 

 

 
 

 

4. Expand the Project Configuration > Configuration Data > Work Items > select 

the Type Category.  

 
 

   

a. To create a new work item category, next to the Choose the Type Category 

to edit, click Add and enter a name for the work item category. This name 

(ID) must be unique.  
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b. You must also add a work item type to a category. Under Work Item 

Types, click Add. (The Work Item Type is what will be visible as a 

Workflow in Rational Asset Manager.)  

 

In the Add Type window enter a work item type name and ID (for 

example, "MyWorkItemType" and "MyWorkItemTypeID").  

 

 
 

Note:  The workflow item type name can be any name that you specify but it 

will be displayed as the workflow in Rational Asset Manager (not the 

workflow category name or the work item type category). The ID must be 

unique   
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c. In the Custom Attributes section, you must add three required attribute 

types: 

 

i. Click Add to select Reuse Existing Attribute, and from the list 

choose Asset link.  

 

Click OK.  

 

Specify these three required: 

 

 

 

 

ii. Click Add, select Reuse Existing Attribute, and from the list 

choose Active state history .Click OK 
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iii. Click Add, select Reuse Existing Attribute, and from the list 

choose Repository id. Click OK 
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d. Click Save.  

 

5. Click the RAM Lifecycle > Open > Process Configuration tab. 

 

 

 

6. Create a new Rational Team Concert workflow. 

a.   In Rational Team Concert, in the Project Area, click Configuration Data > 

Work Items (advanced) > Workflows 
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b.   To create a new workflow, under Choose the Workflow to edit click Add, 

and enter an ID. “CODERunner” 

 

c. In the Name field, enter a name for the workflow. 

 

d. Create the state transition model.  

To create a state click States; then click Add and name the state. Repeat 

this step for each state in your workflow. 

There are “9” states that you have to create: 
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1) Approved 

 
 

2) Deployed 

 
 



     

 

                                  Page 25 of 42                                Rational Support Whitepaper 
   

 

3) Deploying 

 
 

4) Deployment Failed 
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5) Draft  

 
 

 

6) Legal Review 
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7) Medical Review 

 
 

8) Rejected 
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9) Technical Review 

 

 

Once it’s done you should see the all of the 9 states listed on the States table 

 

e. A Start action is required. From the list, enter a state for the Start action by 

choosing an existing state or creating a new one.  

Click Start action “New Action”  
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There are “9” action that need to be added: 

1) Approved, Target State “Medical Review” 

 
 

2) Approved , Target State “Technical Review” 
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3) Approve , Target State “Approved” 

 
 

4) Confirm Deployed, Target State “Deployed” 
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5) Deployed, Target State “Deploying” 

 
 

6) Fail, Target State “Deployment Failed” 
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7) Reject, Target State “Rejected” 

 
 

8) Review, Target State “Legal Review” 
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9) Submit, Target State “Draft” 

 

Optional: You can add icons. They are not required but using them can help 

make the asset display in Rational Asset Manager more understandable to 

users. 

f. Click Save. Once it’s completed you should see all the action listed under 

the “action table” 
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g. To create a transition, click Transitions; then click Add and name the 

transition. Repeat this step for each transition in your workflow and click 

Save when finished. 

i. From “Approved” row go to “Deploying” column select “Deploy” 

 

ii. Deploying row, all column value select “NONE”.  

 

 

iii. From “Deploying” row  go to  “Deployed”  column” select  “Confirm 

Deployed”, go to “Deployment Failed” column select “Fail” 

 

 

iv. From “Deployment Failed” row go to “Deploying” column select 

“Deploy”  

 

 

v. From “Draft” row go to “Legal Review” column  select “Review” 
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vi. From “Legal Review” row go to “Medical Review’ column select 

“Approve” and go to “Rejected” column select “Rejected 

 

 

 

vii. From “Medical Review” row go to “Rejected” column select “Reject” 

and go to “Technical Review” column select “Approve” 

 

 

 

viii. From “Rejected” row go to “Legal Review” column select “Legal 

Review” 

 

 

 

ix. From “Technical Review” row go to “Approved” column select 

“Approved”, go to “Rejected” column and select “Rejected” 
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7.  Bind the new workflow and new work item category. 

a. Select Configuration Data > Work Items > Workflow Bindings.  

 

b. From the lists, select the names of the work item type category and workflow 

that you created in the previous steps. 

 

 

c. Click Save. You are finished with creating the new workflow. 

 

8.  To make your new workflow available in Rational Asset Manager, restart Rational 

Asset Manager or wait ten minutes for the caches to be cleared. Rational Asset 

Manager includes an in-memory cache of workflows. The cache is cleared after 10 

minutes, but if Rational Asset Manager is recycled, it picks up an updated copy of the 

workflows from the Rational Team Concert server. You can also click Tools > Reset 

Caches. In version 7.2, the cache is only cleared on the server that the user is logged 

into. In a cluster environment, this feature might cause a problem because it clears the 

cache on one server, but will not clear the Rational Team Concert cache on other 

servers in the cluster.  

 

9.  To validate that the new workflow is available, log in to Rational Asset Manager 

as an administrator and select Administration and under Communities select a 

community. For the given community click Lifecycles > New Lifecycle. In the list of 

workflows, you should see the name of the workflow that you created. 
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After Rational Asset Manager is recycled, if the new workflow is not visible, the 

workflow might not be configured correctly.  You must use the Rational Team 

Concert client to make the necessary updates (for example, if you did not specify a 

unique ID for your work item, then it will not appear).  Log in to Rational Team 

Concert and review the details of the new work item and workflow to ensure that you 

specified a unique work item type name, the required attributes, a workflow Start 

action, and a correct state transition model. Make changes as needed, save them, 

restart the Rational Asset Manager server and verify that the workflow is available. 
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7 How to import from Development to Test environment 

How to import Library from Development environment to Test environment 

 

Rational Asset Manager (Test Environment) 

 

1. Login as Rational Asset Manager repository Admin click on “Libraries” and 

make sure that you know where is the location where you have exported your 

Rational Asset Manager development library “.zip” file.  

 

 
 

2. Import Library > Browse > location of your “Rational Asset Manager 

development library” > Import 

 

 

3. Click “Enable”  

Note:  We recommend that you select “Enable” instead of “Enable and 

Disassociate” because if you select “Enable and Disassociate” you will lose 

the connection to the Rational Asset Manager library from the development 

environment and the history of where this library came from.  
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4. If there is any conflict Rational Asset Manager will detect and give you a 

warning. If this is the first time that you import the development Rational 

Asset Manager library into the test environment there shouldn’t be any 

conflict.  

 

 

Click  Next 

 

 

Click Enable 

 

 

 

 

5. Next: We need to add the RAM Lifecycle workflow to the test environment 
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Click on Administrator tab > Community, select your community > Click on 

Lifecycles Tab > New Lifecycle > Select you Lifecycle name in our example 

it is “Health Survey2” > Click “Next” 
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Add Lifecycle community manager > Add 

 

 
 

Click “Save and Finish”  
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8 Summary 

 

A successfully migration from Development environment to Test environment is not 

difficult to do. However, a careful planning and a familiarity of how to create the 

Rational Asset Manager process workflow from Rational Team Concert would be a 

great help. Most of the time, the show stopper for this migration task is where, the 

Rational Asset Manager process workflow is not showing up in RAM lifecycle tab. In 

order to avoid this problem, it is recommended you create a dummy Rational Team 

Concert process workflow and familiarize yourself with this process before you 

embark on the migration journey.  

 


